PayPal Processing Issues
Incident Report for Braintree
Resolved
No further impact has been observed since 16:24 UTC.
Posted Feb 14, 2020 - 17:09 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2020 - 16:59 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 14, 2020 - 15:26 UTC
Investigating
We're currently investigating reports of buyers receiving errors on the PayPal checkout screen. Other payment methods are not impacted. An update will be provided as soon as possible.

Symptoms
"Things don't appear to be working at the moment" errors displayed to buyers when using Pay with PayPal

Cause
An upstream issue with PayPal.
Posted Feb 14, 2020 - 14:42 UTC
This incident affected: Transaction Processing (PayPal Processing).