AIB Processing Issues
Incident Report for Braintree
Postmortem

RCA: AIB Failed Authorizations

Date: Friday, 13 April 2018 3:11 - 6:34

All Times in UTC

Executive Summary
Beginning at 3:11, Braintree engineers were alerted to an increase in authorizations resulting in Processor Network Unavailable (3000) responses on the AIB network. After investigation, it was discovered that AIB began sending an unexpected data field in their authorization responses to Braintree. This unexpected data resulted in an inability to process AIB’s responses. Engineers engaged AIB’s support team and AIB rolled back their changes at 6:34, which resolved the issue.

During the incident, impacted authorizations would have been marked as failed in Braintree, but may have been successful with customer issuing banks and cardholders may see pending charges in their account.

Follow-Up

  • Impacted authorizations will not settle to the merchant; funds will remain in a pending state in the cardholder’s account until they have been released back to the cardholder.
  • Braintree and AIB have engaged Visa and MasterCard to assist with releasing all impacted authorizations back to cardholders.
  • Braintree is working with AIB to ensure all system updates that impact Braintree are fully tested and vetted before they are introduced into the production environment.
Posted 2 months ago. Apr 13, 2018 - 19:34 UTC

Resolved
This incident has been resolved.
Posted 2 months ago. Apr 13, 2018 - 06:41 UTC
Update
Braintree engineers continue to work with AIB to resolve the issue. Transactions that fail will have a Processor Response Text of Processor Network Unavailable - Try Again (3000).

Scope: Some European merchants may be affected by this issue. The Braintree gateway is currently up and accepting requests.
Posted 2 months ago. Apr 13, 2018 - 05:12 UTC
Update
Braintree engineers have identified the issue upstream of the Gateway and have engaged AIB to resolve. Transactions that fail may have a Processor Response Text of Processor Network Unavailable - Try Again (3000).

Scope: Some European merchants may be affected by this issue. The Braintree gateway is currently up and accepting requests.
Posted 2 months ago. Apr 13, 2018 - 04:22 UTC
Identified
An issue upstream of our gateway is causing some transactions on the AIB network to fail. Transactions that fail may have a Processor Response Text of Processor Network Unavailable - Try Again (3000).

Scope: Some European merchants may be affected by this issue. The Braintree gateway is currently up and accepting requests.
Posted 2 months ago. Apr 13, 2018 - 03:30 UTC
This incident affected: European Processing.