iOS SDK - Pay with Venmo on iOS 13
Incident Report for Braintree
Resolved
Engineers have released a fix in Braintree iOS 4.29.0. Please update your iOS SDK version and push a new version of your app to the App Store.
Posted 26 days ago. Sep 20, 2019 - 19:20 UTC
Identified
We have identified an issue with customers using a Pay with Venmo payment method on devices running iOS 13. While other flows are not impacted, if you offer Pay with Venmo as a payment method, please update to Braintree iOS 4.29.0 at your earliest convenience. We sincerely apologize for the inconvenience and are working to ensure this issue does not happen again.

Symptoms
Customers using iOS 13 are currently unable to complete the Pay with Venmo app switch flow, meaning creating a one-off payment or storing a new payment method for Pay with Venmo will result in an error for the customer. Customers using earlier versions of iOS, customers with previously-stored Pay with Venmo payment methods, customers using other payment methods like credit cards, Pay with PayPal, Apple Pay, and non-iOS customers are not impacted.

Remediation
Engineers have released a fix in Braintree iOS 4.29.0. Please update your iOS SDK version and push a new version of your app to the App Store.
Posted 26 days ago. Sep 20, 2019 - 01:20 UTC