Elevated Mastercard Declines/Failures
Incident Report for Braintree
Resolved
Decline and failure rates for Mastercard transactions have returned to normal levels as of 18:28 UTC.
Posted 4 months ago. Jul 12, 2018 - 18:47 UTC
Investigating
We have observed an increase in declines and failures for Mastercard transactions since 17:07 UTC. Mastercard is working to resolve the issue. Further updates will be provided as they are available.
Posted 4 months ago. Jul 12, 2018 - 17:38 UTC
This incident affected: United States Processing and European Processing.