Pay with Venmo Service Interruption
Incident Report for Braintree
Resolved
This incident has been resolved.
Posted 3 months ago. Jul 06, 2018 - 18:39 UTC
Investigating
An elevated rate of Pay with Venmo transactions are currently failing due to an issue with the Venmo service. Engineers are investigating.
Posted 3 months ago. Jul 06, 2018 - 18:18 UTC
This incident affected: United States Processing.