Inbound Phone Issues
Incident Report for Braintree
Resolved
Braintree phone service has been restored. Please retry your call to Braintree if you were previously unable to get through to us.
Posted Jun 04, 2020 - 15:18 UTC
Investigating
We are investigating issues with inbound calls to the Braintree Sales, Support, and other telephone numbers; inbound calls may fail or ring without answer. Support remains available via help.braintreepayments.com

Scope: There is no impact on production systems or transaction processing.
Posted Jun 04, 2020 - 14:44 UTC